Cloud Native应用交付

  • 首页
  • 关于本站
  • 个人介绍
  • Downloads
  • Repo
    • Github
    • Container
  • F5
    • F5 Python SDK
    • F5-container
    • F5-LBaaS
  • 社交
    • 联系我
    • 微信/微博
    • 公众号
    • 打赏赞助
行至水穷处 坐看云起时
Cloud Native Application Services: cnadn.net
  1. 首页
  2. 路由器技术
  3. 正文

利用5台2501/14构建Full-mesh型Frame-relay

2006年10月17日 6983点热度 0人点赞 0条评论

方法:在R2/R4上建立一个隧道,将帧中继的DLCI方向通过隧道引到对方.以下输出,被shut的端口表示未用到.

R1:无特殊配置,和正常一样

r1-2514#sh run
Building configuration...

00:36:13: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 655 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1-2514
!
!
ip subnet-zero
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
!
interface Ethernet0
 no ip address
 shutdown
!        
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.0.0.3 103 broadcast
 frame-relay map ip 10.0.0.5 105 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 10.0.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login   
!
end

R2 配置成帧中继交换机,将R1--R3的直接引导,R1--R5和R3---R5的配置一个隧道,利用frame-relay route 将对应的DLCI引导到各自的隧道的DLCI上

r2-2514#sh run
Building configuration...

Current configuration : 1058 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2-2514
!
!
ip subnet-zero
!
frame-relay switching
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.0.0.0
!
interface Tunnel0
 no ip address
 tunnel source Ethernet0
 tunnel destination 8.8.8.4

!
interface Ethernet0
 ip address 8.8.8.2 255.255.255.0
!
interface Ethernet1
 ip address 10.0.3.2 255.255.255.0
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 clock rate 9600
 frame-relay intf-type dce
 frame-relay route 103 interface Serial1 301
 frame-relay route 105 interface Tunnel0 200

!
interface Serial1
 no ip address
 encapsulation frame-relay
 clock rate 9600
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0 103
 frame-relay route 305 interface Tunnel0 201

!
router ospf 1
 log-adjacency-changes
 network 10.0.1.0 0.0.0.255 area 0
 network 10.0.2.0 0.0.0.255 area 0
!
ip classless
ip http server
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R4基本同R2配置,只是少了R1--R3的引导.

r4-2501#sh run
Building configuration...

Current configuration : 847 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname r4-2501
!
!
ip subnet-zero
!
frame-relay switching
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.0.0.0
!
interface Tunnel0
 no ip address
 tunnel source Ethernet0
 tunnel destination 8.8.8.2

!
interface Ethernet0
 ip address 8.8.8.4 255.255.255.0
!
interface Serial0
 ip address 10.0.4.4 255.255.255.0
 shutdown
!
interface Serial1
 ip address 10.0.3.4 255.255.255.0
 encapsulation frame-relay
 clock rate 9600
 frame-relay intf-type dce
 frame-relay route 501 interface Tunnel0 200
 frame-relay route 503 interface Tunnel0 201

!
ip classless
no ip http server
!
!
!        
line con 0
 logging synchronous
line aux 0
 transport input all
line vty 0 4
 login
!
end

R3 无特殊配置

r3-2514#sh run
Building configuration...

Current configuration : 734 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3-2514
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.0.0.0
!
interface Ethernet0
 ip address 10.0.3.3 255.255.255.0
 shutdown
!
interface Ethernet1
 ip address 10.0.4.3 255.255.255.0
 shutdown
!
interface Serial0
 ip address 10.0.2.3 255.255.255.0
 shutdown
 no fair-queue
!
interface Serial1
 ip address 10.0.0.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.0.0.1 301 broadcast
 frame-relay map ip 10.0.0.5 305 broadcast
 no frame-relay inverse-arp
!
ip classless
ip http server
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R5 无特殊配置

r5-2501#sh run
Building configuration...

Current configuration : 893 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5-2501
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Ethernet0
 ip address 10.0.5.5 255.255.255.0
 shutdown
!
interface Serial0
 ip address 172.31.1.5 255.255.255.0
 encapsulation frame-relay
 shutdown
 no fair-queue
 no arp frame-relay
 frame-relay map ip 172.31.1.1 501 broadcast
 frame-relay map ip 172.31.1.2 502 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 10.0.0.5 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 10.0.0.1 501
 frame-relay map ip 10.0.0.3 503
 no frame-relay inverse-arp
!
router eigrp 100
 network 5.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip classless
ip http server
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

验证:
r5-2501#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 372/373/376 ms
r5-2501#ping 10.0.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 376/376/376 ms

r3-2514#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 368/370/372 ms

结果:R1 R3 R5相互都能PING通

附:
复习一下821一个考

点,我配完R1,R3后,还

相关文章

  • 以前单位同事一次DHCP snooping排错经历
  • http://www.cisco.com/warp/public/707/gre_ipsec_ospf.html
  • IPSEC VPN上跑组播
  • NAT-WITH ACL OR ROUTE-MAP
  • ICMP TYPE CODE 对应表
本作品采用 知识共享署名-非商业性使用 4.0 国际许可协议 进行许可
标签: Frame-relay dlci
最后更新:2006年10月17日

纳米

linjing.io

打赏 点赞
< 上一篇
下一篇 >

文章评论

razz evil exclaim smile redface biggrin eek confused idea lol mad twisted rolleyes wink cool arrow neutral cry mrgreen drooling persevering
取消回复

这个站点使用 Akismet 来减少垃圾评论。了解你的评论数据如何被处理。

页面AI聊天助手

纳米

linjing.io

☁️迈向Cloud Native ADC ☁️

认证获得:
TOGAF: ID 152743
Kubernetes: CKA #664
Microsoft: MCSE MCDBA
Cisco: CCNP
Juniper: JNCIS
F5:
F5 Certified Solution Expert, Security
F5 Certified Technology Specialist, LTM/GTM/APM/ASM
F5 Certified BIG-IP Administrator
  • 点击查看本博技术要素列表
  • 归档
    分类
    • AI
    • Automation
    • Avi Networks
    • Cisco ACI
    • CISCO资源
    • F5 with ELK
    • F5-Tech tips
    • F5技术
    • Juniper
    • Linux
    • NGINX
    • SDN
    • ServiceMesh
    • WEB编程
    • WINDOWS相关
    • 业界文章
    • 交换机技术
    • 化云为雨/Openstack
    • 协议原理
    • 容器/k8s
    • 我的工作
    • 我的生活
    • 网站技术
    • 路由器技术
    • 项目案例
    标签聚合
    openstack neutron network api flannel gtm istio F5 envoy nginx irule k8s bigip docker DNS
    最近评论
    汤姆 发布于 8 个月前(09月10日) 嗨,楼主,里面的json怎么下载啊,怎么收费啊?
    汤姆 发布于 8 个月前(09月09日) 大佬,kib的页面可以分享下吗?谢谢
    zhangsha 发布于 1 年前(05月12日) 资料发给我下,谢谢纳米同志!!!!lyx895@qq.com
    李成才 发布于 1 年前(01月02日) 麻烦了,谢谢大佬
    纳米 发布于 1 年前(01月02日) 你好。是的,因为以前下载系统插件在一次升级后将所有的下载生成信息全弄丢了。所以不少文件无法下载。DN...
    浏览次数
    • Downloads - 183,754 views
    • 联系我 - 118,966 views
    • 迄今为止最全最深入的BIGIP-DNS/GTM原理及培训资料 - 116,489 views
    • Github - 103,643 views
    • F5常见log日志解释 - 79,768 views
    • 从传统ADC迈向CLOUD NATIVE ADC - 下载 - 74,619 views
    • Sniffer Pro 4 70 530抓包软件 中文版+视频教程 - 74,320 views
    • 迄今为止最全最深入的BIGIP-DNS/GTM原理及培训资料 - 67,770 views
    • 关于本站 - 60,886 views
    • 这篇文档您是否感兴趣 - 55,491 views
    链接表
    • F5SE创新
    • Jimmy Song‘s Blog
    • SDNlab
    • Service Mesh社区
    • 三斗室
    • 个人profile
    • 云原生社区

    COPYRIGHT © 2023 Cloud Native 应用交付. ALL RIGHTS RESERVED.

    Theme Kratos Made By Seaton Jiang

    京ICP备14048088号-1

    京公网安备 11010502041506号